realogic-software-white

Welcome to the Realogic Tools Knowledge Base

You have arrived at the home for Realogic Tools support.

The first step is to login using the form on your left. Once you do, you will have access to read quick start articles,  learn Realogic Tools tips and tricks and find instructions for installation/upgrading/license activation/deactivation/transfer. 

Export a Single ARGUS File

  1. In ARGUS, open the file to be imported into Realogic Tools
  2. From the [File] menu in ARGUS, click on [OpenARGUS] followed by [Export...]
  3. Select [Machine Data Source]

part i-exporting-single-argus-file

NOTE: If the system moves directly to the initial OpenArgus screen (see right), cancel the export and perform the following steps on the menu bar. [Options], [System], [OpenARGUS] and confirm the "Always Use this Data Source" is not selected. Then, repeat the export process.

  • Select the data source name [Realogic Tools]
  • Click the [OK] button.

The following screen will appear. The name defaults to the ARGUS Property Name and a version number; however, this default name is editable by the user. The second box contains the names of all properties previously exported into the database.

NOTE: The record name for the exported file must be no more than 30 characters and must be followed by a space and then a version number. Non-alphanumeric characters (~, *, !, etc) should be avoided

  • Click on the [Options...] button from the OpenARGUS window
  • On the OpenARGUS Export Options window, verify the following selections are chosen:
 

part-i-oa-export-options

  1. [Input Assumptions] - Select "Yes"
  2. [Calculated Property Values] - Select "Yes"
  3. [Calculated tenant/Unit Detail] - Select "Yes"
  4. [Output Frequency] - check "Monthly Results" only (checking "Annual Results" will not produce incorrect results; however, it will slow down the export.
  5. [Synchronize file to OpenArgus database] - uncheck
  6. [Year and Month ID in Version 8.6 Format] - uncheck
    • Click on [OK] button to close the OpenARGUS Export Options window
    • Click on [Export] button to begin the export.
 

parti-oa-master-tables

ALERT: If you export to a new OpenARGUS database, you will receive the message (above).

Click on the [OK] button and the export will continue

Export Multiple ARGUS Files

ARGUS has a built-in functionality called "Batch processing" that allows the program to calculate or export all files in the directory that contains the last opened ARGUS file. In order to use "Batch Processing," all ARGUS files to be exported must reside in the same directory

NOTE: Prior to using ARGUS "Batch Processing," the destination database must have the requisite tables previously established. If the requisite tables have not been previously established, the following error appears.

To correct this error, export a single building as described in the "Exporting a Single ARGUS File" section of this Quick Start Guide.

  1. In ARGUS, open an ARGUS file in the directory containing all the files to be exported.
  2. From the [File] menu in ARGUS, click on [Batch Processing]
  3. On the ARGUS Batch Processing window, verify that the following selections are made:
    1. [Batch] - Select "Export to OpenARGUS"
    2. [Input Assumptions] - Select "Yes"
    3. [Calculated Property Values] - Select "Yes"
    4. [Calculated Tenant/Unit Detail] O- Select "Yes"
    5. [Output Frequency]- check "Monthly Results" only (checking "Annual Results" will not produce incorrect results; however, it will slow down the export.
  4. Click on the [OK] button to close the ARGUS Batch Processing window
  5. Select [Machine Data Source]
  6. Select the Data Source Name [Realogic Tools]
  7. Click on the [OK] button to begin the export.

Create Your First Excel Workbook

To Open Realogic Tools, first open Microsoft Excel®.

Realogic Tools is an "Add-In" that can be launched directly from within Excel. The methodology to access this Add-In varies slightly depending upon the version of Excel that is being used.

Excel 2013 placeholder

Excel 2013

Click [Add-Ins] on the Excel menu bar.

Click the Realogic Tools menu commmand.

Select the desired module.

 
part-ii-excel-2010-menu

Excel 2010

Click [Add-Ins] on the Excel menu bar.

Click the Realogic Tools menu commmand.

Select the desired module.

 

excel-07

Excel 2007

Click [Add-Ins] on the Excel menu bar.

Click the Realogic Tools menu commmand.

Select the desired module.

 

Excel 2003

Excel 2003

Click Realogic Tools on the Excel menu bar.

Select the desired module.

 

Select the Database

Access your ARGUS data by selecting the Database Source Name (DSN) to be used. All of the properties residing within this data source will be available to you.

Selecting a DSN

  • Click the [ODBC Data Sources] buttopn in ARGUS
  • Select the desired DSN name (typically Realogic Tools v14)
  • Click the [Next] button

Choose Property for Processing

  • Select the property or properties to be processed by highlighting the name(s) under the "Available Properties" heading on the left side of the screen. If all available properties are to be processed, there is no need to highlight any property names – simply click the [Add All] button. All properties will move to the right side of the screen under the heading "Selected Properties."
  • Click the [Add Selected] button. The highlighted properties will move to the right side of the screen under the heading "Selected Properties."
  • Click the [Next] button.

NOTE: If properties have been inadvertently selected in error, move from “Selected Properties” back to “Available Properties” in a similar manner via the use of the [Remove Selected] or [Remove All] buttons.

Entering Your Parameters

  • Enter your report parameters
  • Report Start Date (MM/DD/YYYY)
  • Report Term (Number of Years)
  • Click the [Finish] button.

Install Instructions

There are two steps to install Realogic Tools and activate your license:

  1. Install the latest version of Realogic Tools
  2. Activate your license

NOTE: You must be logged in as the end-user of this product, and you must have administrative permissions, in order to uninstall, install, and activate your product. If you do not have these permissions, speak with your network administrator before proceeding.

Install the Latest Version

You will receive an installation file from Realogic Analytics (MSI file). Save that file on your PC where it is easily accessible to you, such as the Desktop. Double-click the MSI file to run the installation program. The installation program will guide you through the install.

NOTE: You should not install Realogic Tools on an external hard drive.

Windows 8 / 7 / Vista

When prompted for a Destination Folder, it is recommended that you select the default folder C:\RealogicTools. Vista limits installation and access of files under C:\Program Files, and your Realogic Tools™ application may not function properly if installed under that folder. After installation, you must manually start the license service to use the product, even in Demo mode. To do so:

  • Go to Control Panel \ Administrative Tools
  • Right click on Services and choose Run as Administrator. You will need to enter an administrator username and password.
  • Select the service named “ASTSRV”. Right click and select Start.

Activate Your License

You will receive a license code from Realogic Analytics. You will need this code to activate your product. You will also need internet connectivity during the activation process.

NOTE: You should keep a copy of this license code for your records. You will need it for future licensing activity.

  1. Open Excel
  2. From the Realogic Tools menu, click on the "Manage License"

installation-01

  1. A License Manager window will open. Paste in the license code you received from Realogic.

installation-02

  1. Click the “Activate License” button.
  2. After a few seconds, the program will respond with a window that says the license was successfully activated.

installation-03

Manual License Activation

If your corporate IT infrastructure does not allow the standard license activation via Realogic Tools™, the following steps may be used to manually activate your license:

  1. Note your License Number
  2. Note your InstallationID
  3. Obtain an Activation Certificate
  4. Import the certificate to activate your license

Windows XP

You must be logged in as the end-user of this product, and you must have administrative permissions, in order to uninstall, install, and activate your product. If you do not have these permissions, speak with your network administrator before proceeding.

Windows Vista / Windows 7 / Windows 8

You must be logged in as the end-user of this product in order to uninstall, install, and activate your product. If you do not have Administrative permissions, your network administrator will need to provide an administrator username and password in order to uninstall, install, and activate the product.

For Realogic Tools v. 3124 (x.20090724.x) or earlier

Before proceeding, you will need to obtain newer license files from Realogic and copy these files to your installation folder.

Step 1: Note your License Number

When you first purchased Realogic Tools™, you received a license number from Realogic Analytics. You will need that number in order to obtain an Activation Certificate

NOTE: You may want to copy/paste the number into a Word or text file for subsequent steps.

Step 2: Note your Installation ID

You will need this ID in order to obtain an Activation Certificate.

  1. From the Start menu on your computer, run All Programs \ Realogic Tools \ Manual Licensing. The License Manager window will open.

activation-01

  1. Select Import Certificate. The Import Certificate screen will open.

NOTE: You may want to copy/paste the ID into a Word or text file for subsequent steps.

activation-02

Step 3: Obtain Activation Certificate

You will need to browse to the self-serve license activation web site and enter your Installation ID and License Code.

  1. From the Import Certificate screen in Step 2, click on the “Activation Page” link

- OR - Open a web browser and connect to the web site: https://www.internetactivation.com

  1. Enter (or paste) the Installation ID and License Number and click “Generate Unlock Code/Certificate”.

activation-03

  1. Copy the Certificate or click "Copy to Clipboard"

activation-04

NOTE: You may need to allow the web site access to your local computer’s clipboard, as shown below. If so, click “Allow access”.

activation-05

Step 4: Import the Activation Certificate

This step will activate Realogic Tools to run on your computer

  1. Return to the “Import Certificate” screen as described in Step 2.
  2. Paste in the Activation Certificate and click the “Import Certificate” button at the bottom of the screen.

activation-06

  1. You will receive a confirmation that the software has been activated.

activation-07

Upgrade Instructions

The following steps are required to upgrade your installation of Realogic Tools™:

  1. Backup your database
  2. Uninstall the version of Realogic Tools™ currently installed
  3. Install the new version of Realogic Tools™
  4. Activate your license

You must be logged in as the end-user of this product, and you must have administrative permissions, in order to uninstall, install, and activate your product. If you do not have these permissions, speak with your network administrator before proceeding.

Backup Your Database

If you are also upgrading ARGUS Valuation-DCF from version 14 to 15, ignore this step.

Realogic Tools was originally installed with a Microsoft Access database that may be used to transfer property data from ARGUS Valuation-DCF™ to the Realogic Tools program. If you are using this database (RealogicTools_v14.mdb for ARGUS Valuation-DCF version 14; RealogicTools_v15.mdb for ARGUS Valuation-DCF version 15), and you wish to retain the property data in the database after upgrade, then you must backup the database, otherwise it will get overwritten.

  1. Find the folder in which Realogic Tools is installed (default location isC:\RealogicTools)
  2. Rename the database (for example: renameRealogicTools_v14.mdb to RealogicTools_v14_backup.mdb)
  3. After you upgrade your software (see Install New Version below), delete the database that was just installed with the new version (for example: RealogicTools_v14.mdb)
  4. Rename the saved database back to the original name (for example: renameRealogicTools_v14_backup.mdb to RealogicTools_v14.mdb).

Uninstall Realogic Tools

  1. Exit Excel
  2. Go to the Windows Start Menu, Control Panel, Add or Remove Programs (in Vista/Win7: Programs and Features)
  3. Select Realogic Tools
  4. Click the “Remove” button.

upgrade-01

Reinstall Realogic Tools

Manual License Deactivation

If your corporate IT infrastructure does not allow the standard licensing via Realogic Tools™, the following steps may be used to manually deactivate your license:

  1. Note your License Number
  2. Obtain a Deactivation Certificate
  3. Deactivate your License

Windows XP

You must be logged in as the end-user of this product, and you must have administrative permissions, in order to uninstall, install, and activate your product. If you do not have these permissions, speak with your network administrator before proceeding.

Windows Vista

You must be logged in as the end-user of this product in order to uninstall, install, and activate your product. If you do not have Administrative permissions, your network administrator will need to provide an administrator username and password in order to uninstall, install, and activate the product.

For Realogic Tools v. 3124 (x.20090724.x) or earlier

Before proceeding, you will need to obtain newer license files from Realogic and copy these files to your installation folder.

Step 1: Note your License Number

When you first purchased Realogic Tools™, you received a license number from Realogic Analytics. You will need that number in order to obtain a Deactivation Certificate

NOTE: You may want to copy/paste the number into a Word or text file for subsequent steps.

Step 2: Obtain Deactivation Certificate

You will need this ID in order to obtain an Activation Certificate.

  1. From the Start menu on your computer, run All Programs \ Realogic Tools \ Manual Licensing. The License Manager window will open.

activation-01

  1. Select Export Certificate. The Export Certificate screen will open.
  2. Enter (or paste) your License Number and click the “Export Certificate” button at the bottom of the screen.

deactivation-01

  1. The Deactivation Certificate will be generated. Make a copy of it.

NOTE: You may want to copy/paste the certificate into a Word or text file for the next step.

deactivation-02

 

Step 3: Deactivate your License

You will need to browse to the self-serve license deactivation web site and enter your Deactivation Certificate

  1. From the Export Certificate screen in Step 2, click on the “Deactivation Page” link

- OR - Open a web browser and connect to the web site:

https://www.internetactivation.com/ECOSYSTEM/ActivationServer/tiactivate/deactivate.aspx

  1. Paste in the Deactivation Certificate and click “Deactivate License”.

deactivation-03

Uninstall Instructions

  1. Exit Excel
  2. Go to the Windows Start Menu, Control Panel, Add or Remove Programs (in Vista/Win7: Programs and Features)
  3. Select Realogic Tools
  4. Click the “Remove” button.

upgrade-01

Login Form

}